Mac Requirements-OS Support

When installing our Transfer Application software at www.gamegolf.com/downloads please note that our system has minimum requirements for operating systems supported including:

Mac OS X 10.6.8 or higher

Note: If you are running Mac OS X 10.7.5, you will need to use the link HERE to upgrade your operating system. 

Apple is providing free updates to Mac OS X 10.11 El Capitan. To download this upgrade, please click HERE or by searching "El Capitan" in the App Store.

Available USB 1.1 or 2.0 port
512 MB of available hard disk space
Internet access (high speed recommended)

Did you find this article helpful?