"No Device Connected" message when GAME GOLF device plugged in

There can be many reasons for a "No Device Connected" message on the Transfer Application software.

First, make sure you have installed the Transfer Application on a supported operating system.

Mac Requirements
OS X 10.6+ 
If you happen to be running OS X 10.7.5, please upgrade your OS to 10.11 with Apple's free UPGRADE 

Windows Requirements
Windows Vista, 7, 8, or 10
Please note that Microsoft has dropped support of Windows XP and cannot be supported by our platform.

Once you confirm that you have plugged in your device to a supported operating system make sure you are using the micro-usb cable provided with the GAME GOLF unit. It is a custom-molded piece to ensure a proper connection to the device.

Try to connect by plugging in to all different usb ports on the computer. If that doesn't connect, use a different micro-usb cable in all the different ports.  

You could also try close out of the GAME GOLF transfer app, and then re-opening it again.  To take it one step further you could try uninstalling the software and re-installing it at http://www.gamegolf.com/downloads and then try to connect again.

Lastly, when the device is plugged in are you seeing the normal light sequence on the device? The device should be a solid red light upon plugging in, indicating that it's charging.

If you are still experiencing issues connecting the device to the computer or you don't see the normal light sequence, please send us an EMAIL

Did you find this article helpful?